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Introduction

Target Group

ARIS Education Package University Edition tutorial is aimed at students who do not have any
specific knowledge of Process Model and Design, and who would like to teach themselves how
to design, implement and simulate a business process.

Objectives
¢ Introduction to Business Process Analysis and Management
e Business Process Lifecycle
e Modules of ARIS Architect
e Advanced Modeling functionality
e Modeling with ARIS Architect: Creating library models and process models
¢ Introduction to ARIS Methodology
e Testing and evaluating models

Procedure
The tutorial comprises successive exercises that build upon each other. As you work through
them, the configuration is extended step by step.

Database and other related material

All the documents and database required for the tutorial can be downloaded from the
tutorials page of ARIS community.

Go to the BPM Exercises section and download the “BPM Exercises with ARIS: Database &
other related material".

ARIS Community

The ARIS community contains all manuals and technical references available for AEP - PD&A
project. It also provides the ARIS online help topics. These are usually only accessible via the
ARIS user interface.

Sequence of reading
To make the best use of the AEP - PD&A University Edition tutorial, we recommend reading
the documents supplied and performing the exercises in the following order:

e AEP - PD&A Installation Guide

e AEP - PD&A: ARIS Architect Beginner Modeling Exercises- University Edition
e AEP - PD&A: ARIS Architect Advanced Modeling Exercises - University Edition
e AEP - PD&A: ARIS Architect Administration Exercises - University Edition
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http://www.ariscommunity.com/university/tutorial
http://www.ariscommunity.com/university

Sample solution

The AEP - PD&A Administration Exercises - University Edition comes with a sample solution
which has possible solution to each of the exercises in this tutorial. This solution document is
available only to faculty members.

The solution document should not be referred to as the only correct solution to the AEP -
PD&A: ARIS Architect Administration Exercises. Please talk to your professor to get access
to the sample solution.

Important Note

All the Exercises in AEP - PD&A: ARIS Architect Beginner Modeling Exercises- University Edition has
to be done using the United Motor Group database.

e Start ARIS Architect & Designer
e Switch to the Explorer tab. Right-click on United Motor Group database
e Use the “Log in with options” and use Filter: “Entire method”, Version context: “Workspace”

If the UMG database doesn’t already exist in ARIS Architect, you can find it in the BPM Exercises with
ARIS: Database & other related material you downloaded previously (see introduction section)

e Start ARIS Architect & Designer

e Switch to the Explorer tab. Right-click on Local-> Restore Database

e Chose the location of the United Motor Group.adb file (AEP_PDA_ Materials\United Motor
Group\United motor Group.adb)

e From the drop down select Restore as “Non Versionable database™ and click on “Finish”
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Information on how to use this guide

This chapter provides information on how to use this manual. In this manual, menu items, file
names, etc. are identified by the following notational and formatting conventions.

Notation/Formatting Example

Menu items, key combinations, dialog boxes,
file names, model types, model names etc.
are shown in bold.

Click on Help to access the Help menu items
and open further information sources.

Entries via the keyboard, menu item

selections are shown within double quotes " ".

Enter ‘"system" as the user name and
"manager" as the password.
Select Model Types: “EPC” and Object Types:

“Event”, “Function”.

Connection types are shown in italics and are
underlined.

This symbol uses the connection type is
predecessor of.

Sequences of menus and menu items are in
bold and separated by forward slashes.

Right-click on the chart background and
select
Display options/Show absolute
values.

indicator

Sequence of actions and selections are
separated by an arrov=> and are in bold.

Go to Configuration>Method->Model types.

Entries with user-defined content are
highlighted in bold type and enclosed in angle
brackets.

Enter the path <Directory>\PPM.

One-line example texts, e.g. a long directory
path, that need to be shown on several lines
due to a lack of space are separated by the <
(arrow) symbol at the end of the line.

D:\Program Files\ppm\«*
xmN\Adapter
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Particular text sections are specially identified:
Warning

0 Warnings indicate important instructions, where loss of data, semantical error or a safety risk
could arise if they are not observed carefully.

Note
Notes will provide you with additional information.

Tip
Tips indicate references to explanatory notes, e.g. in manuals or in the online help.

See also
This refers to further information on the same topic or related topics within the document.

Hint

0 Hints provide additional information to optimize your results.
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United Motor Group (UMG) scenario

United Motor Group, a global automaker, has teamed up with Software AG consultants to
launch an ARIS Value Engineering project, using the business process transformation method.
After assessing UMG’s strategic positioning and defining objectives, the team identified
critical success factors, which need to be improved to achieve the defined strategy.
Streamlining the business processes is the key to fulfilling this objective.

UNITED MOTOR GROUP
FACT & FIGURES

. Headquarters 30.5 Bill. € Revenue

Frankfurt (GER)
» 21 locations in 16

countries o
+ 25 regional sales & o?o
service organizations 5@: IYARY

Increase of efficiency and
turnover far whole group
Enlargement of model variety
and reducing of stock holding

Car Rental

Financial Services costs
Optimization and extension of
Automotive Engineering overall product portfolio

G software

Figure 1 - Profile of United Motor Group

To create the necessary transparency with regard to business workflows, organizational
structures and system landscapes, ARIS Architect & Designer has been selected as the
modeling platform.

Note
Before getting started with the exercises, please make sure that you have read all the previous

sections thoroughly.
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Exercise 1 - Method Configuration: Derived Model Type

The objective of this exercise is to derive a process model from a Value-Added Chain
Diagram (VACD).

A VACD is used in the United Motor Group project for different purposes. It is used to map
Reference Processes (or process maps) and Scenarios (a rough process model for individual
process map processes), each containing different objects and connections in the process
maps. This project requires the VACD to be named Company Process Map instead of VACD.
Utilize the steps below to derive this model from the model type VACD.

Procedure

1) Start ARIS Architect & Designer. Sign in with your user credentials: user: “system”
and password: “manager”.

2) Log in to Architect_3 database. Right-click Architect_3->Log in with options. Use the
filter “Entire Method”, Versioning state: “Workspace™.

3) Go to the Administration tab of ARIS: ARIS(Top left corner)=>Administration

4) Go to Configuration 2> Method - Model types = Value Added Chain Diagram ->
right-click > New -> Derive model type.

5) Name: “Company Process Map”—=> Next> Next—=> Finish.
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Exercise 2 - Create ARIS Filters

As an ARIS Administrator you would like to create a project filter that will be utilized by all
Project team members (ARIS Designers). As there are three ways to create an ARIS filter it
would be good practice to try all three. Method filters are available at the server level.

Objectives of this exercise:
e Create a New ARIS filter (Customize).
e Create an ARIS filter from an ARIS Database.
e Import an ARIS filter and create a new filter by merging 2 ARIS filters.

Procedure
Create a New ARIS Filter (Customized):

1) Go to the Administration Module - Configuration = Conventions - Filter > New
- Filter. Name your Filter: “UR Filter Handmade” and provide a description 2 Next

®_ Filter Wizard =
Steps Help 1. Create filter
1. Create filter Specify the name for the filter in the language you selected.
2. Select creation mode Language: English {United States) -
£ Cl oS Name: UR Filter handmade
4. Select model types LA
5. Select object types
6. Select connection types
7. Select symbols
8. Assign connection types
9, Select object assignments
10. Select connection assignments
11. Select model attributes
12. Select abject attributes
13. Select connection attributes
GUID: 00000000-0000-0000-0000-000000000000
14, Select attribute order
Type: Methed filter -
15. Select symbol order
g Cancel Help

2) Select creation mode: “Customize” = Next

3) lIgnore the Selection of metamodel - Next

4) Select model types: “EPC”, “VACD” = Next.
Remember to select the processes view below views.
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=, Filter Wizard ==

Steps Help 4. Select model types

1. Create filter Specify which model types are to be allowed by the filter.

Views:
Model 2
2. Select creation mode Model types:

QOrganization =] EPC

3. Select metamodels Data ) Value-added chain diagram

4. Select model types
Functions

5. Select object types Product/Service
6. Select connection types

7. Select symbols

8, Assign connection types

9. Select object assignments

10. Select connection assignments

11, Select model attributes

12. Select object attributes

13, Select connection attributes

14. Select attribute order

Filter model types: | Only show selected ones -

Back @ Cancel Help

15. Select symbol order

5) Select object types: “Event, Function, Organizational unit and Position”

6) Select connection types: “activates, carries out, creates, is predecessor of and is
process-oriented superior” = Next

7) Select symbols:

a. “EPC - Event, Function and Position” ;
b. “VACD - Organization unit (orange), Value-added chain (hover over the VACD
symbol: Type number 141), Value-added chain (Type number 105)” - Next

8) Assign connection types: “EPC” - select ALL / “VACD” - select ALL = Next

9) Select object assignments: Function - select “EPC and VACD” - Next

10) Select connection assignments: do not select anything = Next

11) Select model attributes:
“EPC - Main Group: Select ALL (select nothing from the other Attribute groups)”
“VACD - Main Group: Select ALL (select nothing from the other Attribute groups)”
- Next

12) Select object attributes:
“Event - Main Group: Select ALL (select nothing from the other Attribute groups) /
Function - Main Group: Select ALL (select nothing from the other Attribute groups) /
Organizational unit - Main Group: Select ALL (select nothing from the other Attribute
groups) /
Position - Main Group: Select ALL (select nothing from the other Attribute groups)”
- Next

13) Select connection attributes: do not select anything > Next

14) Select attribute order: do not select anything = Next
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15) Select symbol order: “EPC” - move the Function object to the top of the list /

“VACD” - move the Value-added chain (closed) to the top of the list
- Finish

16) Now re-login with the UR Filter Handmade into the Architect 3 and notice the
changes.

Can you create an Organizational Chart? The answer should be NO.

Create an ARIS Filter from an ARIS Database:

1) Log out of the Architect_3 and log in again with the “Entire method” filter. Now go to
the Administration tab = Configuration 2 Conventions 2> Filter > New > Filter.
Name your Filter: “UR Filter by database” and give it a description - Next.

2) Select creation mode: “Create automatically” 2 Next

3) Select database: “Architect_3” - Finish

4) Now re-login with the UR Filter by database into the Architect_3 and notice the
changes.

Can you create an EPC (row) or an EPC (column)? The answer should be NO.

Import an ARIS Filter and create a Filter by Merging 2 ARIS Filters:

1) Log out of the Architect 3 and go to Administration tab -=> Configuration 2>
Conventions = Filter 2 Import 2 “UR Filter for extended standard.filter” (found in
AEP_PDA Materials \Architect_3\Exercise 02\) - OK

2) Next, select > Configuration = Conventions 2> Filter > New - Filter. Name:
“UR Filter merged” and give it a description = Next

3) Select creation mode: “Merge filters” 2 Next

4) Select filter: “UR Handmade and UR Filter for extended standard” = Finish

5) Now re-login with the UR Filter merged into the Architect_3 and notice the changes.
Can you create an EPC (column)? The answer should be YES.
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Exercise 3 - Create an ARIS Template

As the Value-Added Chain Diagram is often used as an entry model for detailed processes, it
should look particularly appealing. Your task is to create a new template for the Value-Added
Chain Diagram.

Objectives of this exercise:
e Create an ARIS template for Model Type - VACD.
e Assign Template to all VACD.

Procedure
1) Switch to the Administration tab - Configuration - Conventions - Templates >
New > Template. Name the template: “UR Layout Template for VACD” and provide a
description = Next.
2) Select symbols: “Organizational unit (orange), Value-added chain (closed) and Value-
added chain (open)” = Next
3) Select symbol appearance:
e Organizational unit: Fill color: “purple”; Line style: “solid”’; Line weight: “10”;
Shadow;
o Value-Added Chain (open): Fill color: “light blue”; Line style: “solid”; Line
weight: “10”; Shadow;
e Value-Added Chain (closed): Fill color: “blue”; Line style: “solid”; Line weight:
“10”; Shadow = Next.
4) Place symbol attributes: leave it as it is > Next
5) Select connection types: “is _predecessor of” (hover over the connection type and
select type number “118”) = Next

=, Template Wizard

Steps  [GETY

1. Create template
2. Select symbols

3. Select symbol appearance

4. Place symbol sttributes

5. Select connection types

6. Select connection appearance
7. Place connection attributes

8. Select model background

5. Select connection types
Which connection types do you want to include in your template?

Connection types:
is of type
is offered via
is operating resource of
is order basis for
is organization manager for
is oriented at
is owned by
is owner of
is owner of
is part of
is partly consumed
is planned by means of
is platform of
is position of
is predecessor of

is predecessar of

i predecessor of

e reclerecenr of fand-end)
Name: is predecessor of
Type number: 118

APlnsme:  CT_IS_PREDEC_OF_1
Filter «

Information...

Back g Finish

Cancel

Help
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6) Select connection appearance: “is predecessor of” - Line color: “yellow”; Line style:
“solid”’; Line weight: “5”; Arrow towards target: — > = Next

7) Place connection attributes: leave it as it is> Next

8) Select model background: “pink” - Finish

9) Switch to the Explorer tab and open the Core Business Processes (VACD) = Format
- Template - UR Layout Template for VACD - OK -> Yes

10) Now apply it to all future VACDs that will be created in ARIS by selecting ARIS -
Options - Model - For new models > Representation

11) Then select model-type specific templates > Add - VACD > OK -> select the UR
Layout Template for VACD - OK - OK - OK.

In the United Motor Group create New - Model 2 VACD - Template Test to verify that
the template was applied automatically.
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Exercise 4 - ARIS Symbol Editor

Objects with assigned models in ARIS are identified with an Assignment Icon. However, many
decision makers at United Motor Group would like to have a more specific Assignment icon
symbol. You have the job of creating a new assignment icon in the ARIS Symbol Editor and
then replacing the default Assignment icon with the newly created symbol.

Objectives of this exercise:
e Create a new symbol in the ARIS Symbol Editor
e Assign the symbol to the Architect 3 database as the Assignment Icon
e Add a new symbol for a Function

Procedure

1) Launch the ARIS Symbol Editor.

2) Create a new symbol - be imaginative and create it according to your own
requirements.

3) Save your new symbol as “Assignmenticon” and as an “.amf” file to your desktop.

4) Add the newly created Assignment symbol to the Architect_3 Database.

5) Go to Administration tab - Right-click Architect 3 database = Properties = Logo
Management 2 Assignment 2 New - Select the “Assignmenticon.amfFarchitect 3

file from your desktop - OK.
Note

These changes will only take effect after a re-login to the database. Please re-login later
(step 9), since another change which requires a re-login will be made before step 9.

6) You have been supplied with a “ProjectFunction.amf” file (found in
AEP_PDA_Materials\Architect_3\Exercise 04\) that was created in the ARIS Symbol
Editor. Add this symbol as new Function symbol. Configuration = Method = Symbols
- select the Function object (right side window) = New - Derive Symbol

7) Create symbol: Name - “ProjectFunction”—> Next

8) Select graphic: Browse to select the 736-61E Symbol for “ProjectFunction.amf” object
=> Finish

9) The new symbols will be visible/ savailable as soon as you have logged out and logged
in again.

10) Switch to the Explorer tab.

11) Open the Sales Processes EPC which can be found in the Architect_3/United Motor
Group / 2. Processes / Process Architecture / Core Processes / Sales Processes
group to verify that the Assignment Icon has now been changed and you can add  a
ProjectFunction object to the Symbols palette.
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Exercise 5 - Database Administration

As an ARIS Administrator you will need to understand and manage the ARIS database(s) of the
project. Therefore, it is crucial that you consolidate objects with identical names (or other
objects that really mean the same), reorganize the database on a schedule, backup the
database and restore the database when necessary.

Objectives of this exercise:

Consolidation
Reorganization
Backup
Restoration

Procedure
1) Switch to the Explorer tab and log into the Architect_3 database with the “Entire
Method” filter.
2) Select the Core Processes group - Right-click = Find = objects with identical
names (all objects).
3) The Sales Function object will show that it has 3 objects with identical names.
4) Right-click on the Sales object = Consolidate.

15

o Never ever consolidate rules (XOR, OR, AND). This would- for sure- break your modeled

processes.

5) Select objects: leave as it is > Next

6) Select master object: Choose 1 Sales object then select “use as the master” = Next

7) Specify options: Select “merge attributes and delete after consolidation” - Finish

8) Conduct the Find again and notice the Sales object will no longer appear in the results
box.

9) In the Explorer tab, in the Navigation filter select the objects box.

10) Now navigate to United Motor Group / 2. Processes / Process Architecture / Core

Processes group and notice that the Function objects: IT Development, Strategic
Planning and Training are included in this group, but not in any model. (You can
verify this by opening the properties window from the context menu. In that window
go to the “occurrences” section. The list should be empty.)

11) Switch to the Administration tab.
12) Right-click on the Architect 3 database = Reorganize =2 Yes = Yes (the Result box

is below).
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- mReorganization information

The following objects were deleted during reorganization:

Ohbjects Groups

CEMOE-2 “United Motors Grouphd, IT swsterns =
DOET “United Botors Grouphd, IT systerns

CTE “United Botors Group’d, IT systerns

DorAUG “United Motors Grouphd, IT swsterns
DOGET-00 “United Botors Grouphd, IT systerns

CEDAT “United botors Group’d, IT systerns

BUTD

“United Motors Grouphd IT swsterns
The following objects could not be deleted because they are being edited:

Objects Groups Editor

3

o During reorganization all objects that have no occurrence will be deleted. To avoid
deletion of library objects it is best practice to place those objects in a so called library

model, before running reorganization. Do not connect the objects in library models.

13) Log out of the Architect_3 database then right-click on the Architect_3 database 2>
Rename and add your initials after DB (e.g Architect_3 Database_Bob).

14) Select the DB with your initials and Right-click & backup (save to your desktop) 2>
OK.

15) Select the DB with your initials and Right-click > Delete = Yes

16) Right-click on the Local (or your server) - Restore > select the
Architect_3 Database Bob - Finish

17) Now the database is back in ARIS.
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Exercise 6 - What You See Is What You Get (WYSIWYG)

You would like to evaluate EPC’s in your database using a report. In particular, you would like
to output all EPC’s as a graphic and as a list of the functions contained. This will also include
a detailed description. Your report should be executable on all groups in your database.

To do this, create a report script using a report script template and set the desired queries
(follow the steps provided below).

Procedure
Open a predefined report script template in order to adapt it to your requirements by
following the instructions below

1)

2)

3)

4)
5)
6)
7

8)

Go to the Administration tab. In the Navigation window open Reports from the server
item on which the report script is managed.
Right click on Reports=> New -> Category, to create a new Report Category called
“Test Script”. Now right click on the Test Script category to create a new report: New
- Report. The Report Script Wizard will now open.
Specify the entries as follows

a. Name: “UR -Test Script for EPC’s”;

b. Subject: “Training script”;

c. Author: “your name”;

d. Company: “your company’’;

e. Description: “ARIS Training - WYSIWYG: EPC Report Script” >Next.
Select Group in the context. The report will be executed on all groups of the
database>Next.
Select “Use report script template”.
Select the “Blank template™.
As the output format, select “HTML” and “RTF” >Next. The report format for the
output is either in HTML or RTF due to the selection made.
Select “Use cover page”. A cover page is additionally created->Finish.

A cover page with title and date should be displayed. Follow the instructions below to do
this.

17

1)

Display the cover page by expanding the view.
Click the * button in the Cover page line in the Structure column. The cover page is
subsequently expanded.
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2)

3)
4)

5)

6)

Click in the blank space to the right of the cover row and type “Test Report’”. Now
highlight “Test Report”. Use the graphical toolbar to specify the font, font size, color
and style.
In a new line, enter the text “Date:”
Insert a text field to display the current date as follows:

a. Right-click on the right side next to “Date:” Insert = Insert text field;

b. Select “Date:” as the text field>OK.
Highlight “Date:” and use the graphical toolbar to specify the font, font size, color
and style.
Hide the cover page by reducing the display to one line as follows:
In the Structure column click the * button. The cover page is now set and the display
is reduced to one line. The current date of the text field is inserted when the report
is run.

The header and footer should contain general information such as company name, report
name, date, and page number. Therefore, insert the corresponding text fields as
instructed below.

18

1)

2)

3)

4)

5)

Insert a formatting table with one row and three columns in the header
a. Click in the header to place the cursor;
b. In the main menu, click Insert = Insert formatting table;
c. Number of rows: “1”, Number of columns: “3” 20K.
Set the label for the header
a. Click on the left column of the formatting table.
In the main menu, click Insert = Insert image. Select an image or insert a logo.
You can select the “ARIS House.emf” image (found in
AEP_PDA_ Materials\Architect_3\Exercise 06\Symbols for the exercise). Leave
“Image properties” with the default information = Finish;
b. Click the “Align left”” button in the toolbar.
Click on the center column of the formatting table
a. In the main menu, click Insert = Insert text field;
b. Select the “Report name™ as the text field;
c. Click the “Align centered” button in the toolbar.
In the right column of the formatting table, insert the text “Date:”” and a space to
follow it.
a. Right click next to the Date > Insert > Text field: [l Date ;
b. Click the Align right button in the toolbar.
Click on the page footer and insert the label and text fields to display the page
number.
a. Enter the text “Page of”’;
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b. Behind “Page”, insert a text field “Page number’; behind “Page number”,
insert a text field “Total pages”. (i.e. Page “page number” of “total pages”);

c. Highlight both text fields and bold them;

d. Click the Align right button in the toolbar.

Label and text fields in the header and footer are set.

A Table of contents should be inserted automatically; insert the corresponding text field
as indicated here.

1) Place your cursor in the static area in the column Contents.
2) In the main menu, click Insert 2> Text field.
3) Select the “Table of contents” entry from Available text fields list >OK.

A Static area section with a Table of contents text field is automatically inserted. The
Table of contents is automatically created and displayed when the report is run.

A first level heading should output the group path of each queried group. To output the
heading for each group, the heading must be inserted in the repetition area of the
selected groups section. Follow the instructions below.

1) Click in the repetition area (For all: Selected groups in the column Contents) of the
Selected groups section and enter the text Group path.

2) In the main menu, click Insert = Insert data field.

3) Under Items of: selected groups select “Group path” as the data field > Next >
Finish.

4) Highlight this information and select from Edit style field in the toolbar, select the
format Heading 1.

The heading for the output of the group path is displayed in the report script template.

All EPCs of the selected groups should be queried and have a graphical output. In
addition, the model name should be displayed as a heading for each model. To do this,
insert a subsection for the desired query in the repetition area, define the data of the
query and output the heading and the EPC as a graphic, using a data field as described
below.

Inserting a subsection

19 ©2016 Software AG. All rights reserved. This document may be used with a valid University Relations license agreement only.



1) Insert a line break behind the set heading for the group path.

2) In the toolbar, click on the Insert Section here button. The Create section Wizard
opens. >Next.

3) In step 2, Assigned data: go to “Available data”, tick “has repetitions” and select the
“Model list (filterable by type)” item under Item of: Selected groups. Move this
selection to “Data for the repetition” section on the right site using the right arrow >
Next.

4) In the Parameters box, go to Model types and select the “EPC”. Thus, only models of
the type EPC are queried.

5) Enable the Recursive option. All subfolders are included in the query.

6) In the Sorting box select “Sort by Name”-> Finish.

A subsection is inserted with a query of all models of the type EPC.

Inserting a process name as heading

1) In the repetition area of the new subsection (For all: Selected groups. Model list
(filterable by type)) in the column Contents, enter the text “Process:”
2) Insert a data field behind it for displaying the process name.
a. In the toolbar, click on the “Insert data field” button. The Insert data field
Wizard opens;
b. Under Item of: selected groups. Model list (filterable by type), select the
item name > Next-> Finish.
3) Format the text with Heading 2.

A heading which outputs the names of the individual EPCs is inserted.

Inserting a process name as heading

1) Insert a line break behind the heading.
2) In the same way, insert a data field with the data item Graphic under the heading.

A data field which outputs all graphics of the individual EPCs is inserted.

A list of the functions containing the individual EPC’s will be the output. In addition, the
maintained descriptions and the data on time and costs are displayed in each case. For
this, a data table is inserted in the repetition area of the EPC query. The data table
queries all functions of the EPCs. Using data fields, the output of the functions are the
attribute fields’ name, description, time, and costs. The data table queries all functions

20 ©2016 Software AG. All rights reserved. This document may be used with a valid University Relations license agreement only.



of the EPCs and the attribute fields name, description, time and costs of the functions are
output using data fields. These steps are described here:

Inserting a data table

1)
2)

3)

4)

5)

6)
7

Insert two line breaks behind the graphic.

Right click in the repetition area of the subsection of the EPC query, i.e. subsection
(For all: Selected groups. Model list (filterable by type)) and select “Insert/Insert
data table”. The Insert data table Wizard opens.

Enter Number of columns: “4”.

In addition, tick the options “Has header” and “Repeat table header on each page”->
Next.

Under Item of: Selected groups. Model list (filterable by type), select the item
“Object definitions (filterable by type)” >Next.

In the Parameter box go to Object type = “Function”.

In the Sorting Box go to Sort by = Name - Finish.

A new subsection is inserted with a data table which queries the functions of the
individual EPCs.

Formatting the header of the table

1)
2)

3)

4)

Select the first row of the data table.

In the toolbar go to the Table tab and select “Cell Background”. Set any background
color you like by clicking on the color selection field and selecting a color - OK.

In the header of the individual columns, insert the following titles: “Functions,
Description, Average processing time, Costs”.

Highlight the first row; go to the Start tab - Table header from Edit Style.

The first row of the data table is displayed with a colored background and individual
column titles.

Inserting data fields

21

1)
2)

Right click on the second row under the title Functions 2 Insert/data field.
Select the data item Name->Next=>Finish. A data field which lists the individual
function names of an EPC is inserted.
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3) In the second row in the Description column, insert a data field with the data item
Attribute (filterable by type) and in the second step of the wizard select attribute
type “Description/Definition” in the Parameter Box.

4) In the remaining columns, insert further data fields with the data item Attribute and
in the second step of the wizard select the following:

a. For the Average processing time column, select the Attribute type “Avg.
processing time”;
b. For the Costs column, select the Attribute type “Average total costs”.
5) Save the report and run it on the main group.
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Exercise 7 - Semantic Check: Create and Use Rule and Profile

Modelers should check their process models for methodological correctness and completeness
before presenting them to the process manager for approval. To ease the modelers' work
load, you want to put the relevant semantic checks together in a profile. You have identified
several of the existing structure rules as being relevant, but noticed that ARIS does not have
an attribute completeness rule for functions.

Objectives of this exercise:

e Create a Rule

e Create a Profile

e Run a Semantic Check Profile

Procedure

1) Switch to Administration tab.

2) Open Evaluations 2 Semantic checks 2 Select Rule types = Object attribute rules
- New - Rule with name UR UMG Functions = Select object type: Function >
Next

3) Select attributes: select the Add button: “Full name and
Description/Definition”->Finish

4) Select Profiles > New Profile with name “UR UMG EPCs” for Model = choose model
- Next

5) Select Rules:

Object attribute rule: “UMG Functions”;
Structure rules:
o “All functions/events have only one incoming/outgoing connection”
e “Each Path Must Begin and End with an Event or Process Interface”
o “No OR/XOR possible after event”
¢ “Number of Outgoing and Incoming Connections at the Rule”->Finish
6) Switch to the Explorer tab.
7) Run the semantic check profile you have just created on all EPCs with status

"Complete":
Right-click on the United Motor Group - Find 2>Find what: “Models”
a. Type: “EPC”;

b. Click on Attribute filter drop down, Add: “Model Status/Status”;
c. Constraint: “equal to”;
d. Value: “Complete”.
8) Right-click on the Process Customer Inquiry EPC that was found in the results box ->

Evaluate - Start semantic check - Profile: UMG EPCs
Select output setting: “Word document”; save to the desktop; display results 2 Finish.
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About

The AEP - PD&A Architect Administration Exercises- University Edition is a part of a series
of three tutorials:

o AEP - PD&A Architect Beginner Modeling Exercises- University Edition
o AEP - PD&A Architect Advanced Modeling Exercises - University Edition
e AEP - PD&A Architect Administration Exercises - University Edition

These tutorials are aimed to help students who do not have any specific knowledge of Process
Model and Design and who would like to teach themselves how to design, implement and
simulate a business process. Finishing all three tutorials will help students further improve
their knowledge on Business Process Management, modeling and gain expertise in ARIS
Architect.

We hope you enjoyed working with ARIS Architect and AEP- PD&A Architect Administration
Exercises- University Edition.

With this tutorial:

e You learnt the basics of Business Process Management

e You are now familiar with the various modules and functionality of ARIS Architect

e With the successive exercises you familiarized yourself with working on various model
types- Value added chain diagrams (VACD), Organizational charts, Application System
Type Diagram Event-Driven Process Chain (EPC)

e You are now comfortable with creating, testing and evaluating these models with the
help of ARIS Architect

For more information on ARIS products, ARIS Education Packages and to network with
Business Process Management experts, visit ARIS Community.

Thank you!
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