Frank Weyand's picture

Dear community,

last days, we encountered some blogs regarding the start of Express. For some users, ARIS Express failed to start.

During our investigations, we have seen that the new Java release, Java 7, update 6, does not start ARIS Express.

Whenever a new version of the Java Runtime Environment is released, we test ARIS Express. With the developer preview of the "update 6", we did not see any error, but with the release version from Oracle, this error occurres.

Sorry for any inconveniences. But the installed JRE on user's side is completely out of our hands. Furthermore, this is not a bug of ARIS Express.
The only thing we strongly recommend is NOT to do any update to the new Java update, version 7, update 6.In order to avoid any update, please DEACTIVATE the update option in the java control panel.

If you have already this JRE version installed, you can get Java 6 here: http://www.java.com/de/download/manual_v6.jsp

Again, sorry for any inconveniences. We'd be extremely happy, if we could rely on the official JRE, delivered from Oracle, but obviously, it is a danger to get the newest updates of the JRE. We submitted a bug in Oracles bug database and wait for answers...

Best regards,

Frank

_____________________________________________________________________

Liebe Community und Nutzer von ARIS Express,

in den letzten Tagen wurde uns gemeldet, Express würde bei manchen Benutzern nicht mehr starten.

Weitere Untersuchungen dieses Sachverhaltes ergaben, dass das neue JAVA Release, Java 7, update 6 nicht  in der Lage ist ARIS Express zu starten.

Immer, wenn eine neue Version des JRE von Oracle freigegeben wird, so testen wir Express gegen diese neue Version. Mit der "developer preview", einer Vorabversion für Entwickler, sind  diese Fehler nicht aufgetreten.
Mit der offiziell freigegebenen Version tritt dieser Fehler hingegen auf.

Wir möchten uns für die Unannehmlichkeiten entschuldigen, es liegt jedoch nicht in unserer Hand welche Version der Java Laufzeitumgebung bei den jeweiligen Benutzern installiert ist.
Darüber hinaus handelt es sich nicht um einen Fehler bei ARIS Express.

Wir empfehlen eindringlich, KEIN automatischen Update der Java Laufzeitumgebung durchzuführen.
Falls dies schon geschehen ist, oder sie manuell schon Java 7, update 6 installiert haben, hier kann noch die Version 6 heruntergeladen werden: http://www.java.com/de/download/manual_v6.jsp

Wir wären Glücklich, wenn wir uns auf die offiziell freigegebenen Versionen der Laufzeitumgebung von Oracle verlassen könnten, aber offensichtlich ist es ein Risiko, das JRE automatisch zu aktualisieren.
Ein Fehlereintrag in der Fehlerdatenbank von Oracle ist bereits gemacht worden, und wir warten auf Antwort.

Mit besten Grüßen,
Frank