We are getting "String index out of range: -2" error in the "Compare model versions" report script -- Tried running on VACDs & EPCs recently... Screenshot of the error alert is attached herewith.

What could be the possible cause of this error?

How can it be rectified?