StanleyKmmqs's picture

Good day

We are experiencing challenges with ARIS installation. The challenge is with connecting MS SQL to ARIS Application Server, which is the initial step of the installation.

  1. We edited the envset file as per our parameters. Please see text below:

@ECHO OFF

REM

REM You may edit this section for customizing purposes.

REM

REM If you use named instances then append a "\" and the name of your instance

SET MSSQL_SAG_MSSQL_SERVER_NAME=RVSQLECM\SQLI3_DB_ECM

REM The login name that is used to execute this script

SET MSSQL_SAG_MSSQL_LOGIN_NAME=RVSQLECM\SQLI3_DB_ECM\arisadmin

REM name of database that will be created by the script.

SET MSSQL_SAG_DATABASE_NAME=ARIS10DB

REM folder in which the database files should be stored.

SET MSSQL_SAG_FILEGROUP_FILE_DIR=F:\msqldata\ARIS10DB

 

REM credentials of the login that is used by the application.

SET MSSQL_SAG_APP_USER=ARIS10

REM If using % character in your password: Write %% to yield a single % character.

SET MSSQL_SAG_APP_PWD=*ARIS!1dm9n#

 

REM schema names for the default and master tenants

SET MSSQL_SAG_TENANT_DEFAULT=aris_default

SET MSSQL_SAG_TENANT_MASTER=aris_master

When we execute the inst.bat script which is supposed to create the database we get the following error message:

We run the script from ARIS Application Server while logged in with ARIS Application Server Administrator credentials.

 

  1. We changed the username as shown below:

REM The login name that is used to execute this script

SET MSSQL_SAG_MSSQL_LOGIN_NAME=RVSQLECM\SQLI3_DB_ECM\sqladmin

 

When we execute the inst.bat script and we get the following error message:

We run the script from ARIS Application Server while logged in with ARIS Application Server Administrator credentials.

 

  1. We changed the username as shown below:

REM The login name that is used to execute this script

SET MSSQL_SAG_MSSQL_LOGIN_NAME=RVSQLECM\SQLI3_DB_ECM\sqladmin

We executed inst.bat script and got an error message below:

We granted SQL Administrator access to ARIS Application Server

We Run the script from ARIS Application Server while logged in with MS SQL Administrator credentials.

 

 

  1. We then resorted to creating a database manually so that we can only point to it during installation. The DB was created as follows:

 

  • Created ARIS10DB
  • Created ARIS10 APP user with password ********
  • Created schemas (ARIS10_Default & ARIS10_Master)
  • Created users to link to the schemas (ARIS10_ARIS107_Default & ARIS10_ARIS107_Master)
  • Granted impersonate rights to ARIS10 APP User

 

  1. We started the installation setup and populated the Database Connection Parameters GUI with the following:
  • Server:                         RVSQLECM
  • Port:                              1433
  • Instance name:         RVSQLECM\SQLI3_DB_ECM
  • Database name:       ARIS10DB
  • Application user:      ARIS10
  • Password:                   *********
  • Master schema:       ARIS10_Master
  • Default schema:       ARIS10_Default
  1. When we click next we get an error message in red below:

The schema “ARIS10_MASTER” and “ARIS10_DEFAULT” were not found. They either do not exist or are not visible for the user ARIS10.

We are unable to move further with the installation because of this challenge.