Hello,

The certificate has expired on your ARIS Express v2.4d download as of 2019-05-12 @ 7:59 PM.

As a result, installation attempts after this date fail with this error from Java: 

Application Blocked by Java Security
Your security settings have blocked an application signed with an expired or not-yet-valid certificate from running.

Here is the certificate that has expired:

$ jarsigner -verify -verbose -certs PngEncoder.jar
s       1348 Tue Jun 13 11:41:24 EDT 2017 META-INF/MANIFEST.MF
      >>> Signer
      X.509, CN=Software AG, OU=R&D, O=Software AG, L=Darmstadt, ST=Hessen, C=DE
      [certificate expired on 5/12/19 7:59 PM]
      X.509, CN=thawteSHA256Code Signing CA, O="thawte, Inc.", C=US
      [certificate is valid from 12/9/13 7:00 PM to 12/9/23 6:59 PM]
      X.509, CN=thawtePrimary Root CA, OU="(c) 2006 thawte, Inc. - For authorized use only", OU=Certification Services Division, O="thawte, Inc.", C=US
      [trusted certificate]
[...]

 

To fix this, please would you re-sign your ARIS Express software with a valid certificate, so that users can once again install the software.